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Your Data Management SIMPLIFIED.
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The CALUMMA system is a highly adaptable data acquisition
and management system, for complex data. It is able to
handle data of almost aribtrary structure and complexity. The
generic meta data-model of CALUMMA allows the users to
define and customize the system for the actual use case
without any programming.
RISC Software GmbH is a well-established, national and
international IT service company. The company is owned by
the Johannes Kepler University Linz (80%) and Upper
Austrian Research GmbH (20%).
We incorporate mathematics and computer science with
practical experience and thereby develop individual software
solutions for companies, medicine and industry in
interdisciplinary teams.
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Introduction
CALUMMA is a new generation of data management software that combines data
complexity, interface variety and usability. This manual provides a quick and simple entry to
CALUMMA. The quick start guide allows you to create your ontology within minutes and
insert data right away. The ontology can be altered anytime during the creation and data
entry. An automatically generated Web-Interface allows you to insert or edit data manually.
The Web-Interface will change dynamically to changes of your ontology. You can find a
manual to the Web-Interface here: http://calumma.at/.

1.1

Start
After starting the Management Tool the login screen is shown. Insert your database
credentials and click on "Check". If the connection was successful you can insert your
CALUMMA username and password.

License
To import a new license, click on "Import". A file dialog will allow you to choose a license
file "license.clm".When your license is expired please contact RISC Software GmbH.
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Quick Start
This chapter provides an overview of the most important features of CALUMMA, so you can
start right away. The next chapters explain the functions an views in detail.
After logging in and connecting to the database the following screen is shown, the
ontology view. All classes (entities) and enumeration types are shown on the left side in the
"Ontology Explorer". To show and edit the attributes of an entity double-click on it and the
attributes are shown on the right side.

Create entities
To create an entity, click on File->New->New Class.
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Then, the following dialog is shown:

Choose a name for your entity and insert it in the field. Define other options, like access
level, icon and if the entity should be abstract. Klick finish to close the dialog and the entity
will be created. To add your entity to your ontology, drag it from the Ontology Explorer
and drop it to the Form Structure Explorer.
The new entity "Patient" is now displayed in the Form Structure explorer.
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Add Attributes
For every new entity the attributes "ID" and "Name" will be created automatically. More
attributes can be added by clicking on "New Attribute" below the attribute table in the
entity view.
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The following dialog lets you choose the data type and other options for your attribute.
Additionally you can allow/deny null values and define min and max values. Click "Finish"
to create the attribute.

Insert Data
Switch to the data perspective to insert or update data. Click on the "Data" button located
on the upper right corner.

© 2018 RISC Software GmbH

Quick Start

9

In this example, no data has been inserted yet, so the record list is empty. To create a new
"Patient" record, right-click on "Patient" and "Create new Record".
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The following dialog allows you to insert data for your defined attributes. The "ID" is
created automatically.

All fields marked with a "*" are required to be filled with data. Then, click on finish and the
record will be created and shown in the record list.
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Ontology-View
This chapter describes all features of the "Ontology-View". The ontology explorer and the
from structure explorer will be explained, as well as entities, attributes and enumerations.
As soon as entities are created, you can link them with relations and crosslinks. For every
entity you can define form preferences and user permissions. Finally, there is an overview of
the ontology editor, which contains a visual representation of the ontology and its relations.

3.1

User Interface
Ontology Explorer
The ontology explorer contains all created entities and enumerations.

Form Structure Explorer
Add your entities to your ontology by dragging them from the ontology explorer to the
form structure explorer. The resulting hierarchical structure represents the ontology.
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Entity View
Double click on an entity to open the entity view. In the entity view you can edit the name
of the entity and other options, as well as view and edit the list of its attributes.You can also
add and delete attributes in this view.
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Event Log
CALUMMA logs all events and database operations. The logger saves date and time of
changing, adding or deleting entities, attributes and relations. If you create, update or
delete records, this information is also shown in the logger. The history tab lists all opened
records. All events can be deleted by clicking on red "x" in the right upper corner.
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Entities and Attributes
This chapter describes how you can create, edit and delete entities and their attributes. All
entities are displayed in the ontology explorer and can be edited and deleted anytime.
Every entity can have any number of attributes of different data types. There are a number
of different data types for your attributes:
Alphanumeric (String)
Date
DateTime
File
FileLink
Floating Point Number
Integer Number
JSON
Label
Link
Tags
Textfield
Time
True/False
UserGroupID
UserID
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The data type can be altered anytime as long as there are no records of that entity in the
database.

3.2.1

Entities
Create Entities
To create a new entity click on File -> New-> New Class or right click on "Classes" in the
ontology explorer and click on New Class.

The following dialog lets you choose the details for your entity. Define which users have
access to the entity with the access level and select "Abstract" if you want your entity to be
abstract.
Access level details:
Everyone: no restriction, everyone has access to this entity
Group: only users of a specific user group has access
User: only one assigned user has access
Finally, select an icon for your entity and click on "Finish" to create the entity and close the
dialog.
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With entities you can build hierarchies (specializations). For Example Material -> Surgical
Material. To create a new specialization, right click on an entity -> New... -> Derive a new
specialization of "Entity".

To add an entity to the ontology it must be added to the form structure explorer. You can
define one or more entities to be your root entities, which are on top of the hierarchy. All
created entities can be added to your ontology as often as you like. The following screen
shot shows a finished ontology in the form structure explorer.
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Delete Entities
Before you can delete an entity, all records from this entity must be removed from the
database. To delete an entity, right-click on it and select "Delete".
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Initialize Data
To import data from a CSV-File quick and easy, use the function "Initialize Data". This
function is only available for the root entity and as long as there is no data in the database.
The entity can have attributes.

Select the CSV-File by clicking on "Browse...". The file encoding will be selected
automatically, but make sure it is correct and change it manually if necessary. Select the
separator and check if the first line of your file contains the header.
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The next dialog shows all columns of the CSV file. You can activate/deactivate it by
checking/un-checking it. At least one column must be defined as primary key. If the entity
does not contain any attributes you can create them here with a specific data type. If the
entity already contains attributes and they have the same name as the columns in the CSV
file, they will be mapped automatically. For attributes which do not have the same name
you need to create a manual mapping.
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The next dialog shows an overview of the attributes and mappings to be created. Click on
"Finish" to import the data.

3.2.2

Attributes
Add Attributes
To add attributes to your entities, select it first and then click "New Attribute" below the
attributes list. Alternatively, right-click the entity and select Add... -> Add Attribute. The
attributes "Name" and "ID" are always created automatically.

Select the options for your attributes in the following dialog. You can always change them
later in the attributes list. Click on "Finish" to create the attribute and close the dialog. If you
click on "Next" you can set a few more options like the attributes label, record name, view
options, tooltip, URL or group name.
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As long as there a no records which use this attribute in the database you can change the
data type anytime. The name of the attribute can always be changed.
If null-values are allowed, check the option "Allow null values". "Minimum value" and
"Maximum value" define the lower and upper limit of your values for this field. The
attribute table also shows a small lock-icon which is active when the attribute is locked. If it
is, it can't be changed or deleted.

3.2.3

Form Options
Form options for entities mostly affect the CALUMMA Web Interface. You can set up tool
tips, colors and the order of the attributes.
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Option
Label

Explanation

Description for the attribute, for example: measurement units like
meters, or inches.

Use for Name Check this option if you want an attribute to be in the description of
the records.
Use for List
Info Link
Tooltip
Group Name
Color
Order Ref
Order Table

3.2.4

If you activate this function, the attribute will be shown in the table.

Drop a link here, the CALUMMA Web Interface will show a button that
will refer to that link.
The text defined here will be shown as tooltip in the Web Interface.
You can group two or more columns.

You can change the background color of a column with this option.

Add numbers to change the order of the attributes in the description.
Add numbers to change the order of the attributes in the table.
Positive numbers mean ascending, negative numbers descending.

Permissions
Define permissions for every user group for entities, attributes and relations. The combo
box allows you to choose between ALLOW, DENY and INHERITED for every database
operation, create, read, update and delete. You also have the option to reset all
permissions or you can choose one option and set it for all attributes and relations, or
select a user group and overtake the permissions from this group.
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Hierarchy
This tab shows you a list of the defined attributes and in addition the data Validity Checks
and Visibilities.

3.3

Enumerations
Enumerations will be shown in the ontology explorer in the section "Enumeration Types".
Create a new enumeration with File -> New -> New Enumeration Type.
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Insert the name and access level for your entity in the following dialog. Close the dialog
with "Finish" and the enumeration will be shown in the "Enumeration Types".

Like entities, you can add attributes to enumerations. The attributes "ID" and "Name" will
be created automatically. To add more attributes, right-click on the enumeration and
Add.. .-> Add Attribute or click on the "New attribute" button below the attribute table.
Then, in the "Create attribute" dialog, you can set the name and data type for your
attribute.
To view a list of all enumeration values of an enumeration click on the button "Show
enumerations" below the attribute table.
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Add Items
To add values to an enumeration, right-click on the enumeration in the ontology explorer
and click on "Add Item". The next dialog lets you insert data for all attributes of the
enumeration. The new items will be shown as sub-elements of the enumeration. Doubleclick on an item to edit its data. Items can also be arranged hierarchically, just drag&drop
items onto each other to create a hierarchy.
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Add Enumerations to Entities
An enumeration can be added to an entity like an attribute. In this example, the
enumeration "Geschlecht" will be added to the entity "Patient". Double-click on the entity
to open it and drag the enumeration from the ontology explorer to the attribute table of
the entity. Alternatively you can click on the button "New Lookup Table" below the attribute
table. This opens the "Create Relation" dialogue.
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With this dialogue you can create relations. To add the enumeration to the entity just click
"Finish" and you are done. Relations will be explained later in more detail. You can choose
if null values are allowed or if more than one value is allowed.

The enumeration will be shown in the attribute table of the entity.
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Relations
This chapter is about relations between entities and between entities and enumerations.
There are two types of relations, 1:n and 1:1. The m:n relation is implemented with
Crosslinks (see next chapter). There is more than one possibility to create a relation. One of
them was already explained in chapter "Enumerations 23 ".
Create Relations
To create a relation click on File -> New -> New Relation in the menu. The following dialog
opens, choose between 1:n or 1:1 relation and click on "Finish". This example shows how to
create a 1:n relation between "Patient" and "Behandlung".
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The form structure explorer shows the relations in a tree of entities. The entity "Behandlung"
is a sub element of "Patient".
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Delete Relations
The ontology editor shows all relations in a table. Click on the blue circle in the menu to
open the ontology editor, then click on the "Relations" tab to show a table of all relations.
Right-click on a relation to delete it.

3.4.1

Crosslinks
Crosslinks are used to create m:n relations between entities.
Create Crosslinks
There are two possibilities to create a Crosslink. Ether click on the menu File -> New -> New
Crosslink, or drag and drop it in the form structure explorer with pressed "ALT" key. In the
following dialog you can set all options for your Crosslink. If you create the Crosslink via
drag&drop, all necessary fields are already selected. Check the option "Multiple" if you
want to allow multiple Crosslinks and if you check limit to tree records can only be linked
with one data set. If unchecked, all records across the system can be linked.
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Delete Crosslinks
All created Crosslinks are shown in a table in the ontology editor in the "Crosslinks" tab.
Right-click on a Crosslink in this table and select "Delete" to delete a Crosslink.
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Dependency Details
To make attributes dependent on others, for example if you want to hide an attribute
depending on the value of another, you can define a dependency. Click on File -> New ->
New Dependency in the menu.

Then you get the following dialog to configure the dependency. Choose from a list of
dependencies:
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First select the master and slave attribute, then choose the type of dependency. The types
are explained in the following table:
Dependency
Filter

Explanation

The selection of enumeration items will be limited depending on
the selection of the master attribute.

Dynamic Constraint Select this dependency for numeric values. You can define if
values must be equal, minor or greater to another value.
Visibility

Editability
Mapping

An attribute will be hidden or displayed depending on the
selection of another attribute.

Select if an attribute can be edited depending on the selection
of the master attribute.
With mappings you can select for each item of the slave
attribute what items of the master attribute are valid.

Options
Operator: This option is available if the master attribute is a multiple-selection attribute.
Choose from the combo box if the dependency is valid for one item or for all of them.
Master Record Operator: This option is available if the path of the master leads to more
than one master record. Select from the combo box if the dependency is valid for only
one record or for all of them.
Global: Check is item if the dependency is valid globally.
Click on "Next" to select the dependent items, depending on the type of the dependency.
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Ontology Editor
The ontology editor provides an overview and administration of the ontology. Select it
from the menu by clicking on the blue circle. Select the tabs below to get summary tables
and option-menus of entities, attributes, relations, crosslinks, expressions, filters and
visibilities.
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Data View
To open the data view klick on the "Data" button in the right upper corner. Located on the
left side is the ontology explorer which shows the entity and the number of records in
brackets. The root entity is marked in green and underlined, in this case "Patient".

Double-click on an entity to show its records. On the right side, the record view opens and
displays all records in a table.
Create Records
In the data perspective, right-click on an entity and select "Create Record". Parent records
need to be created first.
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Next , enter the data for your records in the dialog, or select values for enumeration values.
(Press and hold the "Ctrl"-Key to select more than one item).
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New records will be shown in the record list on the right side. The lower left corner shows a
toolbox with buttons to create "Behandlungen" and "Material" for "Patient"-Records.

Finalize Records
Records can be finalized which means they can't be edited or deleted. You can re-open
finalized records anytime by right-clicking on the record and select "Re-open".
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Edit Records
Records can be edited any time as long as they are not finalized. Double-click on a record
from the record list to open the record view.
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Delete Records
Single Records can be deleted in the record list by right-clicking on them and selecting
"Delete". Alternatively click on the record and press the "Del"-key on your keyboard. To
delete all records from an entity right-click on the entity and select "Delete all".
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Exploration-View
The exploration view allows you to create a data set with calculated variables and analyze
them in charts and generate reports. You can create any number of logical expression,
calculation and re-use them in new expressions. Then choose from a number of different
chart types to visualize your data.

5.1

Analyze Records
Use the data view to select the records you'd like to analyze. Right-click on the entity and
select "Analyze" or double-click to load the records of an entity and select specific records.
A new Experiment will be created witch will contain an Exploration-set. The exploration-set
contains the records you selected before and all variables you create. Enter a name for your
experiment and switch to the exploration view by clicking the "Exploration" button in the
upper right corner.

Add variables to your exploration set by selecting attributes from the entity.
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Your variables are shown in the exploration view in the "variables" section of your
exploration set. All experiments and exploration sets will be listed on the left side.

In order to add your own variables right-click on your exploration set and select "Define
new variable". In the following example we add the variable "age" to the exploration set.
© 2018 RISC Software GmbH

42

CALUMMA Management Tool

The age of the patients will be calculated with the birth date from each record and the
current year. Create a numeric expression "age" (Alter) by right-clicking on the exploration
set and selecting numeric expression. Below the record table opens the expression view
which contains the expression as a tree. Right-click on the root to add more items. From the
context menu select Numeric Expression -> Date Functions -> Year Diff. The selected
operators will be displayed in the tree and can be edited and deleted in the context menu.

The "Year Diff" function demands a minuend and a subtrahend. In this example the current
Date is the minuend and the birth date is the subtrahend.
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A new column "Age" will be created and the values will be calculated.
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Data Visualization
The CALUMMA Management Tool provides several diagrams to visualize selected data. To
create a diagram right-click on the exploration set, select "Explore" and then the type of
the diagram. The first example shows how to create a scatter chart.

5.2.1

Scatter Chart
The scatter chart offers the possibility to recognize similar value pairs through the position
of the records in the plot. With this chart, dependencies between features can be quickly
recognized. Specify the features (in this example "Weight" and "Age") that need to be
analyzed in the wizard. All data points can be colored by the value you select in the wizard.
In this example we color the bubbles by the sex of the patients.
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Click "Finish" to close the dialog and open the plot-view. The scatter chart consists of 3
parts:
1. Visualization: interactive diagram
2. Legend: select the data points to display
3. Quick Options: frequently used options

1. Visualization
Selection of data points
Click and hold the left mouse button to select specific data points. You can also choose a
color for the selected data points.
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Context menu
Show in RecordView: Selected data points will be shown in the data view.
Hide selected: Hide selected data points.
Show all Records: All data points will be shown again.
Remove from ExplorationSet: Selected data points will be removed from the
exploration set.
Zoom to SelectedPoints: Enlarges the view of the selected data points.
Zoom out: Return to the default view.
Export as Pdf: Save the diagram as PDF file.
2. Legend
Depending on the selection of the variable "Color bubbles by" the legend contains ether a
color bar (numeric values or dates) or a list (enumerations). Use the color bar to select data
points with that specific range of colors or activate/deactivate the checkboxes to show/
hide selected enumerations.

3. Quick Options
1. Color by: Color of the data points.
2. Bubble Size: Size of the data points.
3. Jitter: Random value to move data points away from their position to show all data
points that coincide on one point.
4. Filter: Show selected data points only.
5. Dynamic Contrast: Consider brightness dynamics.
6. Selection Mode: Switch between rectangular or free-hand selection mode.
7. Legend: Show or hide legend.
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8. Option Details: Open options.

Options menu
In addition to the quick options you can edit options for the background of the chart, the
legend and the coordinate system. Select "Density Map" as background to show the density
of the data points or select a color. Choose the color for the legend in the legend section
and select colors for the coordinate system and the selection color in the coordinates
section.

In the menu select "File -> Save Current/Applied Settings" to save the current options and
load them with "File -> Load Settings". To set the current options as default options, select
"Edit -> Set current Settings as Default". To reset the option to the applications default
settings select "Edit -> Reset Default Settings".
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Box Plot
The box plot can be used to show the distribution of the data points. Select a numeric
variable for the y axis and an enumeration type to split the boxes. In the following example
we show the distribution of the weight of the patients split by their sex. A separate box for
each enumeration value will be plotted. In this example for male and female. Click finish to
close the dialog an the plot will be shown in the plot view.

The most left box (Total) contains all values, the box in the center contains only female
values and the box on the right side only male values. On the right side under "Picking" you
can show and hide boxes.

Define the min and max values for the whisker with the Outlier Definition and define the
outliner visibility with the options below the plot. You can select outliners in the plot
directly by clicking and holding the left mouse button. Right-click on the plot and select
Show Records of Box to view the records of this box in the record view. With Show Selected
Outliers you can view the outliners from the box plot in the record view.
© 2018 RISC Software GmbH
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Change the colors of the boxes, background color and die size of the box via the box plot
display settings. You can also select the color and the size of the outliners.

5.2.3

Bar Chart
Select "Bar Chart" from the context menu to open the bar chart wizard.

Select a feature for the x axis (Draw Bar Chart for). In this example we draw a bar chart for
the age of the patients. The bars can be divided in subcategories (Split single bars by). The
plot type defines if the bars are displayed grouped or stacked. The bar height is defined by
the aggregate function you select from the combo box. Select between count, average,
sum, min, max and median. The diagram will be shown below the record view.
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To select bars, click and hold the left mouse button. Right-click on the selected bars to
open the context menu:

The options bar below the chart lets you choose the selection color, the number of classes,
you can hide the legend and export the plot as PDF file. If you have selected a value to split
the bars, the legend will be shown on the right side of the plot. If no split was selected and
COUNT was selected for the bar height, the normal distribution can be shown as an overlay
of the plot.

5.2.4

Line Chart
The line chart is used best for values observed over a period of time. The following
screenshot shows the line chart creation wizard to set the required parameters. You can
group the fields on the y axis by clicking on the button on the bottom right corner.
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In the following example we analyze laboratory results. The variables are applied on the y
axis and the time line is applied on the x axis. The major advantage of the line chart is that
you can define more than one y axis to compare the values of different variables. For
enumeration values you can split the lines (Split lines by).

With he options bar below you can configure your line chart. You can set the line width, the
visibility of the points, if you have more than one variable on the y axis you can synchronize
the scale of the axis by selecting "all variables" in the axes synchronization or you can
synchronize only "grouped variables". This will align the scale of the y-axis so that the lines
are comparable.

© 2018 RISC Software GmbH

52

5.2.5

CALUMMA Management Tool

Parallel Coordinates
The parallel coordinates plot uses all variables from the exploration set. The vertical lines
represent the variables (in this example: Sex, birth date, weight and age) and are connected
through lines. Select values on every axis to see the connecting lines to the other variables.
Select the "AND" selection mode to show lines that connect to every variable, and the "OR"
selection mode also shows you the lines that will go through only one or more of the
variables. The CLEAR mode allows you to only select values of one axis.

5.2.6

Visual Clustering
The visualization of clusters shows records with similar features in a specific area of the
plot. This visualization can also be used if you have more than two variables.
If you find many points close to each other, it means they are similar to each other. As seen
in the scatter plot you can use the density map as background to identify clusters more
easily. The following example shows a density map with three clusters.
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Calendar Map
The calendar heat map visualizes a whole calendar year in a two-dimensional grid. Every
cell of the grid represents a day and each column a week. The intensity of the color of the
cells represent a numeric value, for example an attribute of your entity or aggregations
such as average, min- and max values and sums. This diagram allows you to recognize
trends over a period of time.
To create a calendar map right-click on your data and select "Plotting" and "Calendar
Map". In the next dialog, select a date attribute or variable you want to draw the calendar
map for and the aggregation function and variable you' d like to observe. Then click
"Finish" to create the calendar map.

The calendar map will be shown in the plot view below the records. You can add more
calendar maps to your view by clicking the plus button "Add calendar Map" located at the
bottom left side.

The options bar below lets you configure your calendar map. Change the year and
aggregation function as well as the color variable. You can also set the color and the range
of records that should be included.
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Reports
The CALUMMA Management Tool generates reports that contain basic information of the
records. You can open them via right click on "Explorationset -> Reports".

Full Report
The full report contains all available information of the records in the exploration set. The
bottom of the page contains the "Overview"-Tab and and a separate tab for every variable
that contains more detailed information about that variable. The overview tab contains the
basic statistic information.

© 2018 RISC Software GmbH

Exploration-View

© 2018 RISC Software GmbH

55

56

6

CALUMMA Management Tool

User-View
The user view is only visible to admin users and allows to manage users, user groups,
permissions and languages. Switch to the user perspective by clicking the "User" button in
the upper right corner. All users and user groups are displayed in the "Users Explorer" and
you can assign users to user groups.

Create New User Groups
Users can be assigned to one or more user groups. First, create a new user group by rightclicking on "Users Explorer" and select "Create New Group". Enter a name for your group in
the following dialog and click "Finish". To add an existing user to a user group simply drag
the user from the "Users Explorer" and drop it on the user group.
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Create new User
Right-click on a user group and select "Add new User" to create a new user. You can also
create sup-groups and rename user groups. If you lock a group it can't be changed or
deleted. Deactivate a user group to prevent all users of this group to login and no new
users can be added to the group.
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"Add new User" opens the following dialog. Enter a name and password for the user and
specify the role for the user. You can choose from admin, group admin, user and viewer.
The role defines the permissions for the user.
Role

Admin

Permissions

Create users and user groups, create data structures, exploration
sets and insert data.

GroupAdmin Manage users of this user group, create exploration sets, insert
data.
User

Viewer

Insert data and create exploration sets.
View data and create exploration sets.

Edit this data any time by double-clicking on the user in the "Users Explorer". This opens the
user view where you can edit the details and view the audits. The audits show all changes to
the records in the database from this user.
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Tools and Options
The "Tools" menu offers a number of functions for cleaning and optimizing the database.
The details will be explained in this section.

Clean
The clean function removes all null-values or references to null-values.
Optimize Tables
If you call this function all tables and table index data will be reorganized to reduce
storage space and optimize access to data.
Add missing GUIDs
GUID stands for Global Unique Identifier and is a unique ID to compare records from
different CALUMMA instances. If you load a version 9 or below database schema, the
records don't have a GUID. This function creates GUIDs for all records in the database if
they don't already have one.
Unlock all records
When running this function, all records will be unlocked and can be edited again.
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Preferences
Edit the application settings by clicking Menu -> Tools -> Preferences.

Exe Launcher
The Exe-Launcher can start an external application via a button in the Management Tool.
The data will be loaded from an exploration set and stored into a CSV file. This file is
passed to the application as parameter. In the options menu you can configure the
launcher. Enter the path to the exe file and the directory in witch the CSV file should be
stored. You can add additional parameters to pass to the application and set a tool tip text
for the button.
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R-Connector
You can export data to R or R-Studio if you activate this function in the options menu. R or
R-Studio must be pre-installed on your system. Insert the path to the RStudio.exe file and
select a directory where the CSV file will be stored. This file will be passed to R as a
parameter.

To export the data to R right-click on the records and select "Export" and "Export to R"
from the context menu. The records will be saved in a CSV file, the application creates an R
file that loads the data from the CSV file into R.
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